Desktop 4 - Using Libraries to manage pictures (Mac)

Article Table of Contents:

  1. Introduction
  2. Creating a new Lytro Library
  3. Opening two or more Lytro Libraries at once
  4. Migrating an existing Lytro Library (from Lytro Desktop 3.0.1 and below) into Lytro Desktop 4.0
  5. Copying pictures from one Lytro Library to another
  6. Merging two Lytro Libraries
  7. Using Lytro Libraries with non-startup disks

______________________________________________________________

Introduction

Lytro Desktop 4's Library module lets you view and manage your living pictures.  To access the Library, click on the Library icon on the left hand side of the interface.  

 

The Library is where you can view, sort, rate, flag, and delete pictures.  When you open Desktop 4, a dialog box will prompt you to select an existing or create a new library to open Lytro Desktop with.   

You can create different libraries to store pictures in, and create albums within those libraries to organize your pictures.

You may wish to maintain separate Lytro Libraries for:

  • Pictures taken in different years
  • Pictures taken during a specific photo shoot or event
  • Pictures taken in a specific location 

Having your collection of pictures split among multiple Lytro Libraries may also make it easier to manage backups.

______________________________________________________________

 

Creating a new Lytro Library

  1. From the top-level "File" menu, choose:
    • [Mac] "Choose Library..." > "Create New..."
  2. Type in a name for your new Lytro Library and click "Save."
  3. You can now start importing pictures from your Lytro camera into your new Lytro Library.

______________________________________________________________

 

Opening two or more Lytro Libraries at once

  1. From the top-level "File" menu, choose "Choose Library..."
    • [Mac] You will be presented with a list of all recently opened Lytro Libraries and/or those in your Pictures folder.  
      • [Mac] To open a different Lytro Library in another location (e.g. a backup on an external drive), click "Select Other..." and navigate as needed.
  2. Select your desired Lytro Library.
  3. Click "Open."
    • You may now perform any normal picture or Album operations within, or across, any open Lytro Library as you wish.
    • If you wish to open a Lytro Library originally created in Lytro Desktop 3.0.1 and below, you must first migrate your existing Lytro Library as described below.

______________________________________________________________

 

Migrating an existing Lytro Library (from Lytro Desktop 3.0.1 and below) into Lytro Desktop 4.0

  1. From the top-level "File" menu, choose:
    • [Mac] "Choose Library..." > "Create New..."
  2. Type in a name for your new Lytro Library and click "Save."
  3. A new, empty Lytro Library will be created.
  4. Within that same empty Lytro Library, from the top-level "File" menu, choose the "Import Library..." option.
  5. Navigate to the location of your desired Lytro Library (from Lytro Desktop 3.0.1 and below).
    1. Mac:  Pictures > Lytro (this special folder is known as a 'package,' and its full name is "Lytro.lytrolib")
  6. Click "Open."
    • Please be patient!  This can be an extremely resource-intensive operation, and it may be a while before you see any changes on-screen.
    • Migrating a Lytro Library to Lytro Desktop 4.0 is a one-way process!
      • Although your existing Lytro Library will be retained on your computer, unchanged, in its original location (until or unless you delete it manually), any new pictures you import into Lytro Desktop 4.0 from your Lytro camera in the future will not be able to be imported or viewed with any version below Desktop 4.

______________________________________________________________

 

Copying pictures from one Lytro Library to another

    1. Make sure you have enough room on the hard disk containing the target (destination) Lytro Library to contain all of the pictures you wish to copy.
    2. Arrange the windows displaying your two Lytro Libraries on your monitor(s) so you can see them both.
    3. Select one or more pictures in your source Lytro Library, just as you would when working with Albums within a single Lytro Library.
    4. Click and drag the selected pictures until you see a semi-transparent grouping of pictures begin to move.
    5. Drag those pictures into the Sidebar of the target (destination) Lytro Library.
      • With "All Pictures" selected, drop the photos into the thumbnail image previews to create a new Album of those pictures.
      • To add pictures to an existing Album, drag the group of pictures over the Album name.
      • The album will illuminate and you can drop the pictures into that album, they will then appear in the selected album as well as in "All Pictures" 
    6. NOTE: Please be patient!  This can be an extremely resource-intensive operation, and it may be a while before you see any changes on-screen.

______________________________________________________________

 

Merging two Lytro Libraries

    1. Make sure you have enough room on the hard disk containing the target (destination) Lytro Library to contain the entire source Lytro Library.
    2. Arrange the windows displaying your two Lytro Libraries on your monitor(s) so you can see them both.
    3. Go to the All Pictures view in the source Lytro Library.
    4. Click any picture, then select all pictures using the top-level
      "Edit" menu > Select All.  
      • [Mac] Keyboard shortcut: hold "command" (Apple) and press "a."
    5. Click and drag the selected pictures until you see a semi-transparent grouping of pictures begin to move.  
    6. Drag those pictures into the Sidebar of the target (destination) Lytro Library.  
    7. NOTE: Please be patient!  This can be an extremely resource-intensive operation, and it may be a while before you see any changes on-screen.
    8. If desired, you may then delete the source Lytro Library, although caution dictates preserving all backups indefinitely, whenever you have room available. 

______________________________________________________________

 

Using Lytro Libraries with non-startup disks

    1. Create a new Lytro Library in Lytro Desktop or choose one that you created previously and want to transfer to a different storage drive.
    2. Open your computer's 'Pictures' folder (Macintosh HD>Pictures).
    3. In this folder you will find the Lytro Library file, which has that libraries name and the extension '.lytrolibrary' as the file name.(Lytro Desktop's default save location) 
    4. Click and drag the selected library file to the newly desired storage location. (This could take a very long time if you have a lot of living pictures in your library)
    5. Once the file has finished transferring, launch Lytro Desktop on your computer.
    6. When the 'Open Library...' window automatically opens on launch, click 'Select Other...' and locate the library in its new location.
      • If Lytro Desktop is already open, or if the 'Open Library...' window does not automatically open on launch, please select File > 'Open Library...' from the top bar.
    7. Once the desired library is selected, click 'Open'.
    8. The Lytro Library should now open in Lytro Desktop from its new storage location

 

 

Comments

Powered by Zendesk