Desktop 4 - 工作流程:使用第三方軟體編輯動態相片 (Mac)

Lytro Desktop 4 支援可讓您使用第三方編輯軟體編輯動態相片的匯出與重新匯入工作流程。您可以使用任何支援編輯 (.tif) 檔的第三方程式進行編輯。

首先,選取一或多個您要使用第三方軟體編輯的影像,然後匯入到 Desktop 4。您必須先在 Desktop 4 FIRST 中進任何所需的調整變更,才能用第三方軟體編輯。動畫會在重新匯入編輯過的動態相片套用。

 

  1. 選取您要從任何 Desktop 4 的檢視模式編輯的動態相片縮圖
  2. 瀏覽至「檔案」功能表,並選取「匯出」
    • 對話方塊將會開啟
  3. 為匯出的相片輸入所需的前置詞,例如 "IMG_2014_July_31_EDIT_" 或 "PictureName"
  4. 在「位置」下拉式功能表中為匯出的檔案選取目的地。在選擇的目的地內,Desktop 4 將自動為匯出的檔案建立新的資料夾。
  5. 從「匯出格式」下拉式功能表中選擇「可編輯動態相片」
  6. 按一下「匯出」

  1. 這將產生 7 個 .tif 影像,就是所謂的 TIFF 堆疊,及一個 stack lfp (stack.lfp) 檔案
    • 在您匯出這些影像後,您無法重新命名影像 - 亦即 TIFF 檔或 stack.lfp 檔。如果您變更命名慣例,則將無法在 Desktop 4 中重新匯入到動態相片
    • 您無法變更資料夾結構 - 7 個 tiff 堆疊影像與 stack lfp 檔案必須一起保留在同一個資料夾內,匯出 - 重新匯入程序才能運作。
  2. 如果您正在為您使用的動態相片編輯景深對應則可先匯出可編輯的景深對應 (在您開始編輯前),再重複上述的步驟 1-4
  3. 從「匯出格式」下拉式功能表中選擇「可編輯的景深對應 (.png)」
  4. 按一下「匯出」
  5. 將會建立 3 個檔案:
    • 可編輯的景深對應為 PNG (.PNG)
    • 已套用延伸焦點的 .tiff 影像 (對焦至整個影像)
    • 包含景深對應資料資訊的 .txt 檔
    • 一旦您匯出這些影像後,就無法將影像重新命名。如果您變更命名慣例,則無法在 Desktop 4 中重新匯入景深對應
    • 您無法變更資料夾結構 - 3 個景深對應檔案必須放在相同位置才能夠進行重新匯入程序。
  6. 透過「檔案」->「結束」來結束 Desktop 4

最佳做法:匯出 - 重新匯入工作流程涉及多個檔案與資料夾,因此會混淆。當您編輯影像可編輯景深對應時,會將正本覆寫,除非您先儲存備份版本。以下是我們建議的檔案與資料夾處理方法:

  1. 匯出前,請先為您計劃的編輯內容建立一個新資料夾,例如 "Living Picture Edit #1"
  2. 將所有匯出位置設定至此資料夾
  3. 所有匯出都完成 (可編輯動態相片資料夾,以及 3 個可編輯的景深對應檔案) 後,在名為 "Original Depth Map" 的編輯資料夾內建立一個資料夾,然後將 3 個景深對應檔案拖曳到該資料夾中。
  4. 選取 "Original Depth Map" 資料夾,然後從最上層 (或滑鼠右鍵) 功能表中選擇「檔案」->「複製」
  5. 將複製的資料夾重新命名為 "Edit Depth Map" - 使用此檔案進行編輯
  6. 針對可編輯的動態相片 (TIFF 堆疊) 資料夾重複步驟 4 和 5,並將資料夾命名為 "Original"
  7. 您會得到一個採用正確命名慣例並已組織好的的備份檔案結構。
  8. 命名完這些檔案並將其放在適當位置之後,請勿再予以重新命名或重新定位,否則重新匯入程序將無法執行。
  9. 完成之後,您的資料夾結構看起來應該如下:

在某些狀況下,您可能也想要或需要編輯動態相片景深對應。每個動態相片都有獨一無二的可編輯景深對應 (.png),這是一個灰階資料層,定義了距相機鏡頭的各種表面距離。請將它想成影像的地形地圖。  在下列狀況下,您必須編輯景深地圖:

  • 您需要修正影像中的景深對應錯誤
  • 對影像進行重大變更,例如新增或移除物體
  • 變更影像中相機鏡頭與主體或表面之間的明顯距離
  • 此處提供編輯景深對應的指示

在匯出所有的檔案後,您便可以使用您選擇的第三方軟體進行編輯。 所需要的軟體程式必須能夠編輯採用 ProPhoto RGB 的 16 位元 TIFF 檔。  

  1. 開啟您選擇的編輯程式,如 Adobe Photoshop 或 Lightroom
  2. 從檔案名稱表示為 "original" (只有檔案名稱) 資料夾中開啟 7 個 TIFF 影像,並進行所需的變更。 
    1. 如果您要進行全域調整 (對完整影像產生影響的調整,例如對比或飽和度),您必須確保這些調整項目對每個 TIFF 影像而言都完全相同。您可以將調整圖層複製到其他 TIFF 檔案來達成此目的,方法是使用 Photoshop 中的「複製圖層」選項或
    2. 批次處理 (在 Photoshop 中)
    3. 或者在 Lightroom 中選擇「同步」
  3. 您可以套用任何您在外部編輯軟體中固定使用的編輯設定。建議您為動態相片的 7 個影像全部套用相同的變更,藉此能正確地重新匯入。

  1. 確保您所編輯的是 ProPhoto RGB 色彩空間中的 16 位元 TIFF 影像。
  2. 在 Photoshop 中,平面化您的影像。
  3. 完成變更後,儲存所有的檔案 (透過檔案功能表中的「儲存」,或點擊 command s)。請勿變更檔案名稱。
  4. 變更已寫回檔案 - 如果您使用的是 Photoshop 的匯出或儲存設定功能表,影像或許仍有圖層,這時必須平面化圖層;或者改選「另存新檔」,而不是選擇「儲存」。確定您的影像已平面化,且您選擇的是「儲存」。
  5. 在 Lightroom 中,匯出影像時取消勾選所有方塊,並針對所有下拉式功能表選項選取「正本」。
    1. 注意:您必須將「現有檔案」的 Lightroom 選項變更為「覆寫正本而不警告」,否則您嘗試匯出時會看到錯誤訊息。完成後請務必恢復為原設定!
    2. 如果您一直得到錯誤訊息,您可能必須變更上述選項

儲存堆疊 lfp 檔與景深對應的變更之後,若有需要,可開啟 Desktop 4,以重新匯入檔案並重新建立您的動態相片。

  1. 移至「檔案」,然後選擇「從資料夾匯入」
  2. 瀏覽至您所編輯 tiff 檔案所在的資料夾,並選取該資料夾
    • 請注意,您必須選擇資料夾,您無法匯入單獨的影像
  3. 按一下「開啟」
  4. 如此將會匯入您的動態相片,並會套用您所進行的編輯

正本:

已編輯:

如果您已編輯相片的景深對應,請匯入並將其套用到影像。

  1. 移至「檔案」,並選擇「匯入自訂景深對應」
  2. 瀏覽至您所編輯景深對應所在的資料夾,並選擇編輯過的 png 檔案
  3. 按一下「開啟」
  4. 重新處理相片,將編輯後的景深對應套用到影像

評論

由 Zendesk 提供支援